$re = '/^.*aut[^\s]*\s+[^\s]*co.*$/im';
$str = 'Astronaut control
Autonomous company
Autocomplete';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);