package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Hello.*?World`)
var str = `blablabla Hello blablablabla blablabla Hello blablabla blablabla blablabla Hello I want this to be matched World blablabla blablablablablablablablablablablabla`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}