re = /Hello.*?World/m
str = 'blablabla Hello blablablabla blablabla Hello blablabla blablabla blablabla Hello I want this to be matched World blablabla blablablablablablablablablablablabla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end