import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1-9][0-9]{3,}$";
final String string = "12345\n"
+ "1234\n"
+ "12345678900000\n"
+ "1234.10\n"
+ "12345.10\n"
+ "100\n"
+ "101.50\n"
+ "2000\n"
+ "3000.30\n"
+ "0...000...\n"
+ "000000.0000000\n"
+ "0004\n"
+ "2222\n"
+ "9999\n"
+ "10000 \n"
+ "200001\n"
+ "100000\n"
+ "1000.00\n"
+ "100001\n"
+ "3000.30\n"
+ "100.00 \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}