const regex = /^[1-9][0-9]{3,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1-9][0-9]{3,}$', 'gm')
const str = `12345
1234
12345678900000
1234.10
12345.10
100
101.50
2000
3000.30
0...000...
000000.0000000
0004
2222
9999
10000
200001
100000
1000.00
100001
3000.30
100.00
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}