const regex = /^((?:\+?3)?8)?[\s\-\(]*?(0\d{2})[\s\-\)]*?(\d{3})[\s\-]*?(\d{2})[\s\-]*?(\d{2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:\\+?3)?8)?[\\s\\-\\(]*?(0\\d{2})[\\s\\-\\)]*?(\\d{3})[\\s\\-]*?(\\d{2})[\\s\\-]*?(\\d{2})$', 'gm')
const str = `0670000000
0960000000
0970000000
0980000000
0500000000
0660000000
0950000000
0990000000
0900000000
0560000000
0570000000
0910000000
0920000000
0940000000
+380670000000
+380960000000
+380970000000
+380980000000
+380500000000
+380660000000
+380950000000
+380990000000
+380900000000
+380560000000
+380570000000
+380910000000
+380920000000
+380940000000`;
const subst = `$1($2)$3-$4-$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);