import Foundation
let pattern = #"^((?:\+?3)?8)?[\s\-\(]*?(0\d{2})[\s\-\)]*?(\d{3})[\s\-]*?(\d{2})[\s\-]*?(\d{2})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0670000000
0960000000
0970000000
0980000000
0500000000
0660000000
0950000000
0990000000
0900000000
0560000000
0570000000
0910000000
0920000000
0940000000
+380670000000
+380960000000
+380970000000
+380980000000
+380500000000
+380660000000
+380950000000
+380990000000
+380900000000
+380560000000
+380570000000
+380910000000
+380920000000
+380940000000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1($2)$3-$4-$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)