package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[([^\]]*)\]`)
var str = `Name: [TEXT|enter your name here]
Type of tenancy: [RADIO|This is a periodic tenancy,This tenancy ends on [TEXT|enter date]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}