// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[([^\]]*)\]").unwrap();
let string = "Name: [TEXT|enter your name here]
Type of tenancy: [RADIO|This is a periodic tenancy,This tenancy ends on [TEXT|enter date]]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}