package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([A-Z]\s+){2,}[A-Z])`)
var str = `Welcome to A I: the best W O R L D!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}