$re = '/(([A-Z]\s+){2,}[A-Z])/';
$str = 'Welcome to A I: the best W O R L D!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);