$re = '/\@php\((.+)\)/m';
$str = '@php($timePassed = $item->timePassed()*100) @php($timePassed = (($timePassed) > 0 ? min(100, $timePassed) : 0) )';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);