package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\D?(\d{3})\D?\D?(\d{3})\D?(\d{4})$`)
var str = `1dddd;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}