$re = '/^\D?(\d{3})\D?\D?(\d{3})\D?(\d{4})$/m';
$str = '1dddd;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);