using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#[^\s]+\s";
string input = @"his is a #tag and this is another #love@irc.oftc.net and more text.
# ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}