$re = '/#[^\s]+\s/';
$str = 'his is a #tag and this is another #love@irc.oftc.net and more text.
# ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);