#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)\b([a][\W_]*?)+([p][\W_]*?)+([p][\W_]*?)+([l][\W_]*?)+([e][\W_]*?)+(([\W_]*)([a][\W_]*?)+([n][\W_]*?)+([d][\W_]*?)+)?(([\W_]*)([l][\W_]*?)+([e][\W_]*?)+([m][\W_]*?)+([o][\W_]*?)+([n][\W_]*?)+)?\b"
Local $sString = "a pple and lemon" & @CRLF & _
"" & @CRLF & _
"apple lemon" & @CRLF & _
"" & @CRLF & _
"apple and" & @CRLF & _
"" & @CRLF & _
"apple" & @CRLF & _
"" & @CRLF & _
"apple testing today"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")