const regex = new RegExp('\\b([a][\\W_]*?)+([p][\\W_]*?)+([p][\\W_]*?)+([l][\\W_]*?)+([e][\\W_]*?)+(([\\W_]*)([a][\\W_]*?)+([n][\\W_]*?)+([d][\\W_]*?)+)?(([\\W_]*)([l][\\W_]*?)+([e][\\W_]*?)+([m][\\W_]*?)+([o][\\W_]*?)+([n][\\W_]*?)+)?\\b', 'gim')
const str = `a pple and lemon
apple lemon
apple and
apple
apple testing today`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}