package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:(?:25[0-5]|2[0-4]\d|[01]?\d{1,2})\.){3}(?:25[0-5]|2[0-4]\d|[01]?\d{1,2})\b`)
var str = `<p>My first paragraph.</p>172.217.20.209:80`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}