re = /\b(?:(?:25[0-5]|2[0-4]\d|[01]?\d{1,2})\.){3}(?:25[0-5]|2[0-4]\d|[01]?\d{1,2})\b/
str = '<p>My first paragraph.</p>172.217.20.209:80'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end