$re = '/^(?:[a-zA-Z]|\P{L})+$/mu';
$str = 'Ryszard Czech
Elżbieta Wrońska';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);