#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+(?:\.\d+)?-\d+(?:\.\d+)?"
Local $sString = ""(1-3,1,1)" returns either (1, 1, 1), (2, 1, 1) or (3, 1, 1)" & @CRLF & _
"" & @CRLF & _
""(0.2-0.4,1,1)" returns either (0.2, 1, 1), (0.3, 1, 1) or (0.4, 1, 1)" & @CRLF & _
"" & @CRLF & _
""[1-2,1,2]|foo|bar|[1,8-10,99]""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")