$re = '/\d+(?:\.\d+)?-\d+(?:\.\d+)?/m';
$str = '"(1-3,1,1)" returns either (1, 1, 1), (2, 1, 1) or (3, 1, 1)
"(0.2-0.4,1,1)" returns either (0.2, 1, 1), (0.3, 1, 1) or (0.4, 1, 1)
"[1-2,1,2]|foo|bar|[1,8-10,99]"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);