# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)(\|\s*)([^\|]+)$/\3/gmi;t' <<< "Hlavní kategorie | Podkategorie | Kategorie na konci"