re = /(.*)(\|\s*)([^\|]+)$/mi
str = 'Hlavní kategorie | Podkategorie | Kategorie na konci'
subst = '\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result