$re = '/(^(([0-9]{2})|([0-9]{1}[_]{1})|([_]{2})|([_]{1}[0-9]{1}))-(([0-9]{3})|([_]{1}[0-9]{2})|([_]{2}[0-9]{1})|([0-9]{1}[_]{1}[0-9]{1})|([0-9]{1}[_]{2})|([_]{1}[0-9]{1}[_]{1}))$)|(^(([0-9]{2})|([0-9]{1}[_]{1})|([_]{1}[0-9]{1}))-([_]{3}))/m';
$str = '4_-__';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);