import Foundation
let pattern = #"(^(([0-9]{2})|([0-9]{1}[_]{1})|([_]{2})|([_]{1}[0-9]{1}))-(([0-9]{3})|([_]{1}[0-9]{2})|([_]{2}[0-9]{1})|([0-9]{1}[_]{1}[0-9]{1})|([0-9]{1}[_]{2})|([_]{1}[0-9]{1}[_]{1}))$)|(^(([0-9]{2})|([0-9]{1}[_]{1})|([_]{1}[0-9]{1}))-([_]{3}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"4_-__"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)