using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=click=)([^&]+)";
string input = @"https://play.google.com/store/apps/details?id=air.com.littlebigplay.games.premium.plurals&click=541255b82bc957475c7b6222d1a980a5&mysuffix={HELLO_WORLD}&optid=541255b82bc957475c7b";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}