// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\x{2019}{2})(.+?)(\x{2018}{2})").unwrap();
let string = "’’احرام باندھتے وقت کاغسل‘‘";
let substitution = "$3$2$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}