$re = '/^(?!.*js\/chunks.*$).*/m';
$str = 'js/chunks/abc.js
css/app.css
index.php
js/main.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);