re = /^(?!.*js\/chunks.*$).*/m
str = 'js/chunks/abc.js
css/app.css
index.php
js/main.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end