# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\G[^\s.]*\K\./\\./gm;t' <<< "DXa0.Xa1.a2 p1 p2 deviceName a=157.585p b=54.46u $x=106.124 $y=107.996 $a=0"