import re
regex = re.compile(r"\G[^\s.]*\K\.", flags=re.MULTILINE)
test_str = "DXa0.Xa1.a2 p1 p2 deviceName a=157.585p b=54.46u $x=106.124 $y=107.996 $a=0"
subst = "\\\\."
result = regex.sub(subst, test_str)
if result:
print(result)