$re = '/\.(s(?:css|ass)|css)$/m';
$str = '.scss
.sass
.css
.ass
How would I make it not match .ass?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);