#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a.*href.?=.?["'](?:\b\w+://)?([\w-]+(?:\.[\w-]+)+)[/:?]?.*?["'].*?>?(?:</)?.?>"
Local $sString = "<a href="http://stepic.org/courses">" & @CRLF & _
"<a href='https://stepic.org'>" & @CRLF & _
"<a href='http://neerc.ifmo.ru:1345'>" & @CRLF & _
"<a href="ftp://mail.ru/distib" >" & @CRLF & _
"<a href="ya.ru">" & @CRLF & _
"<a href="www.ya.ru">" & @CRLF & _
"<a href="../skip_relative_links">" & @CRLF & _
"<a target="blank" href='http://sas-_0123d.ifmo.ru:1345'>" & @CRLF & _
"<a href='http://neerc.ifmo.ru:1345'>" & @CRLF & _
"<a href="../some_path/index.html">" & @CRLF & _
"<a href="https://www.ya.ru">" & @CRLF & _
"<a href="ftp://mail.ru/distib" >" & @CRLF & _
"<a href="bya.ru">" & @CRLF & _
"<a href="http://www.ya.ru">" & @CRLF & _
"<a href="www.kya.ru">" & @CRLF & _
"<a href="../skip_relative_links">" & @CRLF & _
"<a href="http://stepic.org/courses">" & @CRLF & _
"<a class = "hello" href= "http://ftepic.org/courses" id="dfdf">" & @CRLF & _
"<p class = "hello" href= "http://dtepic.org/courses">" & @CRLF & _
"<a class = "hello" href = "http://a.b.vc.ttepic.org/courses">" & @CRLF & _
"<a href='https://stepic.org'>" & @CRLF & _
"<a href='http://neerc.ifmo.ru:1345' >" & @CRLF & _
"<a href = "ftp://mail.ru/distib" >" & @CRLF & _
"<a href= "ya.ru">" & @CRLF & _
"<a href ="www.ya.ru">" & @CRLF & _
"<a href="../skip_relative_links">" & @CRLF & _
"<link rel="image_src" href="https://examaple.org/files/6a2/72d/e09/6a272de0944f447fb5972c44cc02f795.png" />" & @CRLF & _
"<a href="http://www.gtu.edu.ge/index_e.htm" target="_top">Georgian Technical University</a>" & @CRLF & _
"<a href="http://stepic-2.org/courses">" & @CRLF & _
"<a href="ftp://www.mya-2.ru">" & @CRLF & _
"<a href='https://stepic-2.org'>" & @CRLF & _
"<a link href='http://neerc.ifmo-2.ru:1345'>" & @CRLF & _
"<a title=test download="http://test.com"; href="test.com" class="my test" style=>" & @CRLF & _
"<a title=test class="my test" href= "test1.com:8080/test/path?get=http://test2.ru/?true"; rel="nofollow" style=>" & @CRLF & _
"<a title=test meta="whatever http://test1.com"; href = "test.com?get=http://test2.ru/?true"; class="my test" style= >" & @CRLF & _
"<a target="blank" href='http://sasd.ifmo-2.ru:1345'>" & @CRLF & _
"<a href='http://neerc.ifmo-2.ru:1345'>" & @CRLF & _
"<a href="../some_path/index-2.html">" & @CRLF & _
"<a href="https://www.ya-2.ru">" & @CRLF & _
"<a href="ftp://mail-2.ru/distib" >" & @CRLF & _
"<a href="bya-2.ru">" & @CRLF & _
"<a href="http://www.ya-2.ru">" & @CRLF & _
"<a href="www.kya-2.ru" >" & @CRLF & _
"<a href="../skip_relative_links-2">" & @CRLF & _
"<a href="http://stepic-2.org/courses">" & @CRLF & _
"<a class = "hello-2" href= "http://ftepic-2.org/courses" id="dfdf">" & @CRLF & _
"<p class = "hello-2" href= "http://dtepic-2.org/courses">" & @CRLF & _
"<a class = "hello-2" href = "http://a.b.vc.ttepic-2.org/courses">" & @CRLF & _
"<a href='https://stepic-2.org'>" & @CRLF & _
"<a href='http://neerc.ifmo-2.ru:1345' >" & @CRLF & _
"<a href = "ftp://mail-2.ru/distib" >" & @CRLF & _
"<a href= "ya-2.ru">" & @CRLF & _
"<a href ="www.ya-2.ru">" & @CRLF & _
"<a href="../skip_relative_links">" & @CRLF & _
"<link rel="image_src" href="https://examaple.org/files/6a2/72d/e09/6a272de0944f447fb5972c44cc02f795.png" />" & @CRLF & _
"<a href="http://www.gtu.edu-2.ge/index_e.htm" target="_top">Georgian Technical University</a>" & @CRLF & _
"<a class-8 = "hello-2" href= "http://zzz.last.test-1.stepic.org/courses" id="dfdf">" & @CRLF & _
"<a class-4-4 = "hello-2-raz" href = "http://zzz.last.test-2.stepic.org/courses" >" & @CRLF & _
"<a href ="https://stepic.org/media/attachments/lesson/24471/02">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")