import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[[0-9]+\\](\\s+)?\\[(\\s+)?(.+?)(\\s+)?\\](\\s+)?\\[[A-Z0-9]";
final String string = "02:05:31,624 TRACE [com.test.enterprise.process.module.AZZADM13] (default task-6) [2019-06-10][02:05:31][5330985][TESTSRV ][AZZADM13 ][process - ENTER ]\n"
+ "02:05:31,624 TRACE [com.test.enterprise.process.module.AZZADM13] (default task-6) [2019-06-10][02:05:31][5330985] [ TESTSRV ] [AZZADM13 ][process - ENTER ]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}