$re = '/\[[0-9]+\](\s+)?\[(\s+)?(.+?)(\s+)?\](\s+)?\[[A-Z0-9]/m';
$str = '02:05:31,624 TRACE [com.test.enterprise.process.module.AZZADM13] (default task-6) [2019-06-10][02:05:31][5330985][TESTSRV ][AZZADM13 ][process - ENTER ]
02:05:31,624 TRACE [com.test.enterprise.process.module.AZZADM13] (default task-6) [2019-06-10][02:05:31][5330985] [ TESTSRV ] [AZZADM13 ][process - ENTER ]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);