$re = '/ByLearn\w*/m';
$str = 'O Felipe nasceu em 1996 e desde 2007 estuda programação. Em 2019 ele fundou a ByLearn. Em Maio de 2020 já existem mais de 28000 ByLearners! pelo mundo.
PS: Eu funciono com ByLearn3rs também!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);