re = /ByLearn\w*/m
str = 'O Felipe nasceu em 1996 e desde 2007 estuda programação. Em 2019 ele fundou a ByLearn. Em Maio de 2020 já existem mais de 28000 ByLearners! pelo mundo.
PS: Eu funciono com ByLearn3rs também!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end