$re = '/^(?:https?:\/\/(www|m|)\.(youtube\.com\/watch\?v=|youtu.be\/))([a-zA-Z\d_-]{11})$/m';
$str = 'https://www.youtube.com/watch?v=d9VZImZAbaI';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);