re = /^(?:https?:\/\/(www|m|)\.(youtube\.com\/watch\?v=|youtu.be\/))([a-zA-Z\d_-]{11})$/m
str = 'https://www.youtube.com/watch?v=d9VZImZAbaI'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end