$re = '/^abc_[a-zA-Z_]+(?<!_app)_code$/m';
$str = 'abc_abc_code
abc_titer_code
abc_google_twitter_code
abc_twitter_twitter_code
abc_google_google_google_google_code
abc_something_code
abc_abc_app_code
abc_titer_app_code
abc_google_twitter_app_code
abc_twitter_twitter_app_code
abc_google_google_google_google_app_code
abc_google_another_ending';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);