import re
regex = re.compile(r"^abc_[a-zA-Z_]+(?<!_app)_code$", flags=re.MULTILINE)
test_str = ("abc_abc_code\n"
"abc_titer_code\n"
"abc_google_twitter_code\n"
"abc_twitter_twitter_code\n"
"abc_google_google_google_google_code\n"
"abc_something_code\n\n"
"abc_abc_app_code\n"
"abc_titer_app_code\n"
"abc_google_twitter_app_code\n"
"abc_twitter_twitter_app_code\n"
"abc_google_google_google_google_app_code\n\n"
"abc_google_another_ending")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")