using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^message-id: (\S+)$";
string input = @"Message-ID:
<GVAP278MB0310DE2FC290B07EFC17D9BF9F989@GVAP278MB0310.CHEP278.PROD.OUTLOOK.COM>
";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}