re = /^message-id: (\S+)$/i
str = 'Message-ID:
<GVAP278MB0310DE2FC290B07EFC17D9BF9F989@GVAP278MB0310.CHEP278.PROD.OUTLOOK.COM>
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end