using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([^\[\]]+)\]";
string substitution = @"{$1}";
string input = @"public static int[] BigLogoArr = [100,100] ;// процент видности второй и третьей картинки логотипа
public static TSound ThrowSound []=[BM.SoundLoad(""_Incbin/Sounds/Throw"")];
private int BloodColor[]=[100,10,10] ;// Цвет крови игрока
Local ShadowDistance[]=[-2,-2];
Local ShadowColor[]=[15,57,12];// уже *2
//x y z
private int PrimHandPos[]=[2,2,8];
private int SecHandPos[]=[1,-1,8];
private int CrawlHandPos[]=[2,0,2];
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}