import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^\\[\\]]+)\\]";
final String string = "public static int[] BigLogoArr = [100,100] ;// процент видности второй и третьей картинки логотипа\n"
+ " public static TSound ThrowSound []=[BM.SoundLoad(\"_Incbin/Sounds/Throw\")];\n"
+ " \n"
+ " private int BloodColor[]=[100,10,10] ;// Цвет крови игрока\n\n"
+ " Local ShadowDistance[]=[-2,-2];\n"
+ " Local ShadowColor[]=[15,57,12];// уже *2\n\n"
+ " //x y z\n"
+ " private int PrimHandPos[]=[2,2,8];\n"
+ " private int SecHandPos[]=[1,-1,8];\n"
+ " private int CrawlHandPos[]=[2,0,2];\n"
+ " ";
final String subst = "{$1}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}