using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^map\s*\(\s*\""([^\""]+)\""\s*,\s*\(([\d, ]+)\)\s*\)";
string input = @"map(""hello"", (0, 0, 1, 0, 0, 1)); //hello? ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}