import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^map\\s*\\(\\s*\\\"([^\\\"]+)\\\"\\s*,\\s*\\(([\\d, ]+)\\)\\s*\\)";
final String string = "map(\"hello\", (0, 0, 1, 0, 0, 1)); //hello? ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}