package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\D(\d+\.\d+)`)
var str = ` 1 675.04 318.26
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}